<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-title"
          content="Lynnwood Today - A news website covering all things Lynnwood, WA">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="https://lynnwoodtoday.com/xmlrpc.php">

    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>County Human Rights Commission seeks nominations for 2022 awards - Lynnwood Today</title>
	<link rel="canonical" href="https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="County Human Rights Commission seeks nominations for 2022 awards - Lynnwood Today" />
	<meta property="og:description" content="The Snohomish County Human Rights Commission is now accepting nominations for candidates for recognition of their contribution to making the county a place that honors the inherent dignity and the equal and inalienable rights of all people. Nominations are accepted and awards are presented in the following categories: Human Rights Award Young People’s Award Law..." />
	<meta property="og:url" content="https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/" />
	<meta property="og:site_name" content="Lynnwood Today" />
	<meta property="article:published_time" content="2022-10-18T04:26:01+00:00" />
	<meta property="article:modified_time" content="2022-10-18T04:26:44+00:00" />
	<meta name="author" content="Administrator" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Administrator" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://lynnwoodtoday.com/#website","url":"https://lynnwoodtoday.com/","name":"Lynnwood Today","description":"A news website covering all things Lynnwood, WA","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://lynnwoodtoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/#webpage","url":"https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/","name":"County Human Rights Commission seeks nominations for 2022 awards - Lynnwood Today","isPartOf":{"@id":"https://lynnwoodtoday.com/#website"},"datePublished":"2022-10-18T04:26:01+00:00","dateModified":"2022-10-18T04:26:44+00:00","author":{"@id":"https://lynnwoodtoday.com/#/schema/person/9f4e3f838823f895d4f92decab74fd62"},"breadcrumb":{"@id":"https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/"]}]},{"@type":"BreadcrumbList","@id":"https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://lynnwoodtoday.com/"},{"@type":"ListItem","position":2,"name":"County Human Rights Commission seeks nominations for 2022 awards"}]},{"@type":"Person","@id":"https://lynnwoodtoday.com/#/schema/person/9f4e3f838823f895d4f92decab74fd62","name":"Administrator","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://lynnwoodtoday.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/cab918c5ec4286235c57e2e5242a9528?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/cab918c5ec4286235c57e2e5242a9528?s=96&d=mm&r=g","caption":"Administrator"},"url":"https://lynnwoodtoday.com/author/teresa-wippel/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdn.streetinteractive.com' />
<link rel='dns-prefetch' href='//checkout.stripe.com' />
<link rel='dns-prefetch' href='//maps.google.com' />

<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Feed" href="https://lynnwoodtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Comments Feed" href="https://lynnwoodtoday.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Lynnwood Today &raquo; iCal Feed" href="https://lynnwoodtoday.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; County Human Rights Commission seeks nominations for 2022 awards Comments Feed" href="https://lynnwoodtoday.com/county-human-rights-commission-seeks-nominations-for-2022-awards/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='dashicons-css'  href='https://lynnwoodtoday.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='https://lynnwoodtoday.com/wp-content/plugins/wunderground/assets/css/wunderground.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css'  href='https://lynnwoodtoday.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-mini-calendar-block.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://lynnwoodtoday.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://lynnwoodtoday.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.css' type='text/css' media='all' />
<link rel='stylesheet' id='if-menu-site-css-css'  href='https://lynnwoodtoday.com/wp-content/plugins/if-menu/assets/if-menu-site.css' type='text/css' media='all' />
<link rel='stylesheet' id='toronto-pro-css'  href='https://lynnwoodtoday.com/wp-content/themes/toronto-pro/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='themeplate-styles-css'  href='https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='wdp-frontend-style-css'  href='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='decent-comments-widget-css'  href='https://lynnwoodtoday.com/wp-content/plugins/decent-comments/css/decent-comments-widget.css' type='text/css' media='all' />
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery/jquery-1.12.4-wp.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-migrate/jquery-migrate-1.4.1-wp.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/widget.min.js' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/position.min.js' id='jquery-ui-position-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' id='wunderground-widget-js-extra'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"7d0616b2f1","ajaxurl":"https:\/\/lynnwoodtoday.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/wunderground/assets/js/widget.min.js' id='wunderground-widget-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.streetinteractive.com/init-2.min.js?v=1.43.8&#038;ver=5.8.6' id='broadstreet-cdn-js'></script>
<script type='text/javascript' id='read-more.js-js-extra'>
/* <![CDATA[ */
var pp_vars = {"publisher_id":"1889daee-a7bd-47be-b7c7-cbd985d6be31","widget_endpoint":"https:\/\/gadget.pico.tools","plugin_version":"1.0.2","widget_version":"10.18.22.07.28","pico_context":"gadget","post_id":"136284","post_type":"post","post_title":"County Human Rights Commission seeks nominations for 2022 awards","taxonomies_for_this_post_type":["category","post_tag","post_format"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","wp_theme","tribe_events_cat","restaurant_category"],"show_read_more_button":"1","taxonomies":{"category":["county government"]},"resource_ref":"name=county-human-rights-commission-seeks-nominations-for-2022-awards"};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/pico/includes/js/read-more.js' id='read-more.js-js'></script>
<script type='text/javascript' src='//maps.google.com/maps/api/js?sensor=false&#038;libraries=geometry%2Cplaces&#038;v=3.22&#038;key=AIzaSyA0BD9Xwz_Fk_Q2bqDKMqa3xMs6StV0cjM&#038;ver=1.0.0' id='google-map-js'></script>
<link rel="https://api.w.org/" href="https://lynnwoodtoday.com/wp-json/" /><link rel="alternate" type="application/json" href="https://lynnwoodtoday.com/wp-json/wp/v2/posts/136284" /><link rel='shortlink' href='https://lynnwoodtoday.com/?p=136284' />
<link rel="alternate" type="application/json+oembed" href="https://lynnwoodtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flynnwoodtoday.com%2Fcounty-human-rights-commission-seeks-nominations-for-2022-awards%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://lynnwoodtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flynnwoodtoday.com%2Fcounty-human-rights-commission-seeks-nominations-for-2022-awards%2F&#038;format=xml" />
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','county-government','county-human-rights-commission-seeks-nominations-for-2022-awards','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["county-government","county-human-rights-commission-seeks-nominations-for-2022-awards","post"],"url":"county-human-rights-commission-seeks-nominations-for-2022-awards"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(525, { domain: 'partner.streetinteractive.com'});
 });</script><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-BCEFNZMCNX"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-BCEFNZMCNX');
</script><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://lynnwoodtoday.com"><link rel="alternate" href="https://lynnwoodtoday.com/wp-json/tribe/events/v1/" />
        <script type="text/javascript">
            var jQueryMigrateHelperHasSentDowngrade = false;

			window.onerror = function( msg, url, line, col, error ) {
				// Break out early, do not processing if a downgrade reqeust was already sent.
				if ( jQueryMigrateHelperHasSentDowngrade ) {
					return true;
                }

				var xhr = new XMLHttpRequest();
				var nonce = 'add9902bcc';
				var jQueryFunctions = [
					'andSelf',
					'browser',
					'live',
					'boxModel',
					'support.boxModel',
					'size',
					'swap',
					'clean',
					'sub',
                ];
				var match_pattern = /\)\.(.+?) is not a function/;
                var erroredFunction = msg.match( match_pattern );

                // If there was no matching functions, do not try to downgrade.
                if ( typeof erroredFunction !== 'object' || typeof erroredFunction[1] === "undefined" || -1 === jQueryFunctions.indexOf( erroredFunction[1] ) ) {
                    return true;
                }

                // Set that we've now attempted a downgrade request.
                jQueryMigrateHelperHasSentDowngrade = true;

				xhr.open( 'POST', 'https://lynnwoodtoday.com/wp-admin/admin-ajax.php' );
				xhr.setRequestHeader( 'Content-Type', 'application/x-www-form-urlencoded' );
				xhr.onload = function () {
					var response,
                        reload = false;

					if ( 200 === xhr.status ) {
                        try {
                        	response = JSON.parse( xhr.response );

                        	reload = response.data.reload;
                        } catch ( e ) {
                        	reload = false;
                        }
                    }

					// Automatically reload the page if a deprecation caused an automatic downgrade, ensure visitors get the best possible experience.
					if ( reload ) {
						location.reload();
                    }
				};

				xhr.send( encodeURI( 'action=jquery-migrate-downgrade-version&_wpnonce=' + nonce ) );

				// Suppress error alerts in older browsers
				return true;
			}
        </script>

		<link rel="icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.category .page-header .page-title{
	font-size: 40px;
  text-transform: uppercase;
  color: #4db2ec;
}

@media only screen and (min-width: 960px) {
  .widget:not(.bs_zones){
		width:300px;
		margin-left: auto;
    margin-right: auto;
	}
	
}
.site-navigation ul li a{
	padding: 13px;
}
.show-street-dialog .container {
    width: inherit;
}
.support-main a {
    border: none;
    box-shadow: none;
    color: #fff;
    background: #074d81;
    font-size: 15px;
    padding: 3px 5px;
    text-shadow: none;
    border-radius: 3px;
    margin-bottom: 10px;
    display: inline-block;
    margin-right: 5px;
}
.decent-comments .comment-excerpt {
    word-break: break-word;
}

.banner-btm-ad .container {
	width: 100% important;
}		</style>
		
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-38313383-1"></script>
    <script>
        window.dataLayer = window.dataLayer || [];

        function gtag() {
            dataLayer.push(arguments);
        }

        gtag('js', new Date());

        gtag('config', 'UA-38313383-1');
    </script>

</head>

<body class="post-template-default single single-post postid-136284 single-format-standard wp-custom-logo tribe-no-js tribe-theme-parent-toronto-pro tribe-theme-child-lynnwood-child group-blog">

<div class="header-top-area">
    <div class="container">
        <div class="row">
            <div class="col-md-10 col-xs-12">
                <div class="top-menu-area">
                    <div class="top-nav-item">
                        <p>Tuesday, October 18, 2022</p>
                    </div>
                    <div class="top-nav-item">
                        <div class="menu-header-eyebrow-menu-container"><ul id="menu-header-eyebrow-menu" class="menu"><li id="menu-item-93293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93293"><a href="https://mltnews.com">MLTNEWS</a></li>
<li id="menu-item-93294" class="active-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-93294"><a href="https://lynnwoodtoday.com">LYNNWOOD TODAY</a></li>
<li id="menu-item-93295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93295"><a href="https://myedmondsnews.com">MY EDMONDS NEWS</a></li>
<li id="menu-item-93296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93296"><a href="https://myneighbornewsnetwork.com/">MY NEIGHBORHOOD NEWS NETWORK</a></li>
</ul></div>                    </div>
                </div>
            </div>
            <div class="col-md-2 col-xs-12">
                <div class="footer-social-icons">
                    <a href="https://facebook.com/lynnwoodtoday" target="_blank"><i class="fa fa-facebook"></i></a>
                    <a href="https://twitter.com/lynnwoodtoday" target="_blank"><i class="fa fa-twitter"></i></a>
                    <a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
                </div>
            </div>
        </div>
    </div>
</div>

<div id="page" class="hfeed site">

    <div class="mobile-membership-btn-area text-center visible-xs">
        <a class="membership-btn" href="https://lynnwoodtoday.com/membership/">Become A Supporter</a>
    </div>

    <!--    banner top add-->
                <div class="top-add-module text-center">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">
                        <div id="custom_html-5" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1487"></broadstreet-zone></div></div>                    </div>
                </div>
            </div>
        </div>
    
    <!-- ******************* navigation area ******************* -->
    <div class="wrapper-fluid wrapper-navbar" id="wrapper-navbar">

        <a class="skip-link screen-reader-text" href="#content">Skip to content</a>
        <div class="header-area hidden-xs hidden-sm">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">

                        <div class="header-logo-area">
                            <a class="navbar-brand" href="https://lynnwoodtoday.com/"
                               title="Lynnwood Today" rel="home">
                                <img src="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2021/04/Lynnwood-Today-Picton-Blue-Logo-Transparent-1.png"
                                     srcset="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2021/04/Lynnwood-Today-Picton-Blue-Logo-Transparent-1.png 1x, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2021/04/Lynnwood-Today-Picton-Blue-Logo-Transparent-1.png 2x"
                                     alt="Lynnwood Today">
                            </a>
                            <!--							<span class="site-tagline hidden-xs">Powered by -->
                            <!--</span>-->
                        </div>

                        <div class="header-search-box pull-right">
                            <a href="#"><i class="fa fa-search"></i></a>
                            <form method="get" action="https://lynnwoodtoday.com" class="header-search-form"
                                  role="search">
                                <input name="s" id="search-input" class="search-field form-control" placeholder="Search"
                                       required="" value="" type="search" autofocus>
                                <button type="submit"><i class="fa fa-search"></i></button>
                                <input type="hidden" name="post_type" value="post">
                            </form>
                        </div>

                        <div class="header-sub-menu-area pull-right">
                            <!-- The WordPress Menu goes here -->
                            <div class="menu-sub-menu-container"><ul id="sub-menu" class="menu"><li id="menu-item-93217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93217"><a href="https://lynnwoodtoday.com/about/">About <i class="fa fa-angle-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-124326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124326"><a href="https://lynnwoodtoday.com/about/">Lynnwood Today</a></li>
	<li id="menu-item-93218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93218"><a href="https://lynnwoodtoday.com/w-video-studio/">W Video Studio</a></li>
	<li id="menu-item-93219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93219"><a href="https://lynnwoodtoday.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li id="menu-item-93283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93283"><a href="https://lynnwoodtoday.com/advertise/">Advertise</a></li>
<li id="menu-item-93221" class="sub-menu-support-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-93221"><a href="https://lynnwoodtoday.com/membership/">Support Us</a></li>
</ul></div>                        </div>

                    </div>
                </div>
            </div>
        </div>

        <nav class="site-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

            <div class="navbar">

                <div class="container">

                    <div class="row">

                        <div class="col-md-12">

                            <div class="navbar-header">

                                <!-- .navbar-toggle is used as the toggle for collapsed navbar content -->
                                <button type="button" class="navbar-toggle" data-toggle="collapse"
                                        data-target=".navbar-responsive-collapse">
                                    <span class="sr-only">Toggle navigation</span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                </button>

                                <!-- Your site title as branding in the menu -->
                                <a class="navbar-brand hidden-md hidden-lg" href="https://lynnwoodtoday.com/"
                                   title="Lynnwood Today" rel="home">
                                    <img src="https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/images/logo-white.png"
                                         srcset="https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/images/logo-white.png, https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/images/logo-white.png"
                                         alt="Lynnwood Today">
                                </a>
                                <span class="site-tagline-mobile">Powered by Lynnwood Today</span>

                            </div>

                            <!-- The WordPress Menu goes here -->
                            <div class="collapse navbar-collapse navbar-responsive-collapse pull-left"><ul id="main-menu" class="nav navbar-nav"><li id="menu-item-101330" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-101330"><a title="COVID-19" href="https://lynnwoodtoday.com/category/health-and-fitness/covid-19-coronavirus/">COVID-19</a></li>
<li id="menu-item-93278" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93278"><a title="Obituaries" href="https://lynnwoodtoday.com/obituaries/">Obituaries</a></li>
<li id="menu-item-85924" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-85924"><a title="EAT / PLAY / LIVE" href="https://lynnwoodtoday.com/eat-live-play/">EAT / PLAY / LIVE</a></li>
<li id="menu-item-93252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children nav-item menu-item-93252 dropdown"><a title="Events" href="/events/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-93257" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-93257"><a title="Submit Event" href="/events/community/add">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-85188" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-85188"><a title="Health &#038; Fitness" href="https://lynnwoodtoday.com/health-fitness/">Health &#038; Fitness</a></li>
<li id="menu-item-76759" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-76759"><a title="Home &#038; Real Estate" href="https://lynnwoodtoday.com/home-real-estate/">Home &#038; Real Estate</a></li>
<li id="menu-item-93279" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93279"><a title="Sound Silver Living" href="https://lynnwoodtoday.com/sound-silver-living/">Sound Silver Living</a></li>
<li id="menu-item-109731" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-109731"><a title="Weather" href="https://lynnwoodtoday.com/weather/">Weather</a></li>
<li id="menu-item-112331" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-112331"><a title="Restaurants" href="https://restaurants.lynnwoodchamber.org/">Restaurants</a></li>
<li id="menu-item-132506" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-132506"><a title="Election 2022" href="https://lynnwoodtoday.com/category/election-2022/">Election 2022</a></li>
<li class="pc-search-for-mobile"><form method="get" action="https://lynnwoodtoday.com" class="header-search-form" role="search"><input name="s" id="search-input" class="search-field form-control" placeholder="Search" required="" value="" type="search" autofocus><button type="submit"><i class="fa fa-search"></i></button><input type="hidden" name="post_type" value="post"></form></li></ul></div>
                        </div> <!-- .col-md-11 or col-md-12 end -->

                    </div> <!-- .row end -->

                </div> <!-- .container -->

            </div><!-- .navbar -->

        </nav><!-- .site-navigation -->
                    <nav class="trnto-secondary-menu visible-lg-block visible-md-block">
                <div class="container">
                    <div class="row">
                        <div class="col-md-12">
                            <div class="menu-secondary-menu-container"><ul id="secondary-menu" class="nav navbar-nav"><li id="menu-item-93280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children nav-item menu-item-93280 dropdown"><a title="Columns" href="https://lynnwoodtoday.com/category/columns/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Columns <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-95279" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-95279"><a title="Day Trip Discoveries" href="https://lynnwoodtoday.com/category/columns/day-trip-discoveries/">Day Trip Discoveries</a></li>
	<li id="menu-item-95281" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95281"><a title="Fitness Corner" href="https://lynnwoodtoday.com/category/columns/fitness-corner/">Fitness Corner</a></li>
	<li id="menu-item-95282" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95282"><a title="Forward Thinking" href="https://lynnwoodtoday.com/category/columns/forward-thinking/">Forward Thinking</a></li>
	<li id="menu-item-95284" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95284"><a title="Healthy Eating" href="https://lynnwoodtoday.com/category/health-and-fitness/healthy-eating/">Healthy Eating</a></li>
	<li id="menu-item-128788" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-128788"><a title="Home + Work" href="https://lynnwoodtoday.com/category/home-work/">Home + Work</a></li>
	<li id="menu-item-95286" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95286"><a title="Just Around the Corner" href="https://lynnwoodtoday.com/category/just-around-the-corner/">Just Around the Corner</a></li>
	<li id="menu-item-95291" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95291"><a title="Kids are Bookin&#039; It" href="https://lynnwoodtoday.com/category/kids-are-bookin-it/">Kids are Bookin&#8217; It</a></li>
	<li id="menu-item-95292" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95292"><a title="Looking Back" href="https://lynnwoodtoday.com/category/looking-back/">Looking Back</a></li>
	<li id="menu-item-95293" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95293"><a title="Lynnwood Lifestyles" href="https://lynnwoodtoday.com/category/columns/lynnwood-lifestyles/">Lynnwood Lifestyles</a></li>
	<li id="menu-item-95294" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95294"><a title="Playtime" href="https://lynnwoodtoday.com/category/columns/playtime/">Playtime</a></li>
	<li id="menu-item-95295" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95295"><a title="Recommended Reads" href="https://lynnwoodtoday.com/category/columns/recommended-reads/">Recommended Reads</a></li>
	<li id="menu-item-95296" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95296"><a title="Restaurant News" href="https://lynnwoodtoday.com/category/columns/restaurant-news/">Restaurant News</a></li>
	<li id="menu-item-109167" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-109167"><a title="Under the Weather" href="https://lynnwoodtoday.com/category/under-the-weather/">Under the Weather</a></li>
	<li id="menu-item-113138" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-113138"><a title="The Writer&#039;s Desk" href="https://lynnwoodtoday.com/category/the-writers-desk/">The Writer&#8217;s Desk</a></li>
</ul>
</li>
<li id="menu-item-93194" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93194"><a title="Photos" href="https://lynnwoodtoday.com/category/photos-2/">Photos</a></li>
<li id="menu-item-93196" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93196"><a title="Public Safety" href="https://lynnwoodtoday.com/category/public-safety-2/">Public Safety</a></li>
<li id="menu-item-93281" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93281"><a title="Schools" href="https://lynnwoodtoday.com/category/schools/">Schools</a></li>
<li id="menu-item-93197" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93197"><a title="Sports" href="https://lynnwoodtoday.com/category/sports-2/">Sports</a></li>
<li id="menu-item-93282" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93282"><a title="Marketing Services" href="https://lynnwoodtoday.com/business-resources-kaufer-dmc/">Marketing Services</a></li>
</ul></div>                        </div>
                    </div>
                </div>
            </nav>
        
        
    </div><!-- .wrapper-navbar end -->

<div class="wrapper" id="single-wrapper">

    <div id="content" class="container">

        <div class="row">

            <div id="primary"
                 class="col-md-8 content-area">

                <main id="main" class="site-main" role="main">

					
						
<article id="post-136284" class="post-136284 post type-post status-publish format-standard hentry category-county-government">

	
	<header class="entry-header">
		<h2 class="entry-title">County Human Rights Commission seeks nominations for 2022 awards</h2>
		
		<div class="entry-meta">
			
			<span class="posted-on">Posted: October 17, 2022 </span><span class="post-views"><i class="fa fa-eye"></i> 13 </span>		</div>

	</header><!-- .entry-header -->

	<div class="entry-content">
		<div id="pico"><p style="font-weight: 400;">The Snohomish County Human Rights Commission is now accepting nominations for candidates for recognition of their contribution to making the county a place that honors the inherent dignity and the equal and inalienable rights of all people.</p>
<p style="font-weight: 400;">Nominations are accepted and awards are presented in the following categories:</p>
<p>Human Rights Award</p>
<p>Young People’s Award</p>
<p>Law Award</p>
<p>Diversity Visionary Award</p>
<p>Community Organization Award</p>
<p>Educator’s Award</p>
<p style="font-weight: 400;">To be eligible for nomination, the recipient must be a Snohomish County resident as of the date of nomination. Nominees must have made a significant contribution to the promotion and protection of human rights in Snohomish County and been active in this area between August 2021 and August 2022.</p>
<p style="font-weight: 400;">For more information, contact SCHRC Secretary Angela DiFilippo at <a href="mailto:angela.filippo@snoco.org">angela.filippo@snoco.org</a>.</p>
<p style="font-weight: 400;">To access the nomination form and instructions, go to <a href="https://snohomishcountywa.gov/149/Human-Rights-Commission">snohomishcountywa.gov/149/Human-Rights-Commission</a>.</p>
<p>&nbsp;</p>
</div>	</div><!-- .entry-content -->

	<footer class="entry-footer"></footer><!-- .entry-footer -->

	
</article><!-- #post-## -->


													
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/county-human-rights-commission-seeks-nominations-for-2022-awards/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://lynnwoodtoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="form-group comment-form-comment">
    <label for="comment">Comment <span class="required">*</span></label>
    <textarea class="form-control" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
    </div><div class="form-group comment-form-author"><label for="author">Name <span class="required">* (First and last required)</span></label> <input class="form-control" id="author" name="author" type="text" value="" size="30" aria-required='true' required /></div>
<div class="form-group comment-form-email"><label for="email">Email <span class="required">*</span></label> <input class="form-control" id="email" name="email" type="email" value="" size="30" aria-required='true' required /></div>
<div class="form-group comment-form-address"><label for="address">City/State of Residence <span class="required">*</span></label> <input class="form-control" id="address" name="address" type="text" value="" size="30" aria-required='true' required /></div>
<div class="form-group comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30" /></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='136284' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7e3dddc77f" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="131"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	        <p style="color: green; font-weight: bold;">
            Real first and last names — as well as city of residence — are required for all commenters.
            <br/> This is so we can verify your identity before approving your comment.
        </p>
	
</div><!-- #comments -->
						                        <!-- add subscribe from -->
						<div class="subscribe-panel">

	<h3 class="subscribe-heading">Lynnwood Today</h3>
	<p><strong>Sign Up for Our Daily Lynnwood Newsletter</strong></p>

	<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.8.7 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-71903 mc4wp-form-theme mc4wp-form-theme-red" method="post" data-id="71903" data-name="Newsletter" ><div class="mc4wp-form-fields"><div class="subscribe-form torontopro-mailchimp-form">
    <input type="email" name="EMAIL" placeholder="Enter your email address" style="width:60% !important;margin-bottom:10px !important" required />
    <script src="https://www.google.com/recaptcha/api.js" async defer></script>
	<div class="g-recaptcha" data-sitekey="6LeL930UAAAAADYqKapnDDA3PYjy1BfUlNbH13Nw"></div>
  	<input type="submit" value="Sign Up" style="width:60%;margin-top:10px" />
</div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1666078487" /><input type="hidden" name="_mc4wp_form_id" value="71903" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin -->
</div>

<!--                        <section class="related-posts-area">-->
                            <!-- <h4 class="related-posts-area-heading">-->
							<!--</h4>-->

							
<!--                            <div class="trnto-next-post-nav" data-id="--><!--"></div>-->

<!--                        </section>-->

					
                    <div class="back-to-home text-center">
                        <a href="https://lynnwoodtoday.com">BACK TO HOME</a>
                    </div>

                </main><!-- #main -->

            </div><!-- #primary -->

            <div id="secondary" class="col-md-4 widget-area hidden-xs hidden-sm single-post-sidebar"
                 role="complementary">

				<aside id="bs_zones-44" class="widget bs_zones"><div><broadstreet-zone zone-id="83032" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-22" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="32659" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-59" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="99160" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-21" class="widget bs_zones"><div><broadstreet-zone zone-id="48295" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="decent_comments_widget-3" class="widget widget_decent_comments_widget"><h3 class="widget-title">Recent Comments</h3><div class="decent-comments"><ul><li><div class="comment"><span class="comment-author">Betty L. Gaeng</span><span class="comment-date"> Oct 17, 2022 at 12:23 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/looking-back-location-confusion-plus-this-and-that/#comment-36516">Looking Back: Location confusion and Lynnwood history, Part 1</a></span><span class="comment-excerpt">Bob -- your best chance to find the history of your home is at the Snohomish County Courthouse in Everett.</span></div></li><li><div class="comment"><span class="comment-author">Bob Elliott</span><span class="comment-date"> Oct 17, 2022 at 11:44 am</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/looking-back-location-confusion-plus-this-and-that/#comment-36515">Looking Back: Location confusion and Lynnwood history, Part 1</a></span><span class="comment-excerpt">Very interesting Betty. Thank you. Betty how can I find out the history of my 1911 old home on old</span></div></li><li><div class="comment"><span class="comment-author">Lisa Weber</span><span class="comment-date"> Oct 17, 2022 at 8:58 am</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/looking-back-lynnwood-moves-forward-to-incorporation-part-3/#comment-36514">Looking Back: Lynnwood moves forward to incorporation, Part 3        </a></span><span class="comment-excerpt">Excellent article. Thank you! </span></div></li><li><div class="comment"><span class="comment-author">Nancy Hulbert</span><span class="comment-date"> Oct 16, 2022 at 11:14 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/lynnwood-retail-theft-police-sting-nets-eight-arrests/#comment-36508">Lynnwood retail theft police sting nets eight arrests</a></span><span class="comment-excerpt">Knowing our state reputation of being "soft on crime" I see a slap on the wrist, 30 days community service</span></div></li><li><div class="comment"><span class="comment-author">John Nolte</span><span class="comment-date"> Oct 16, 2022 at 8:27 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/just-around-the-corner-custer-former-home-of-loretta-lynn/#comment-36504">Just Around the Corner;  Custer &#8212; former home of Loretta Lynn</a></span><span class="comment-excerpt">According to my wife who was born and raised in the area, her home was on the corner of Sunrise</span></div></li></ul></div></aside><aside id="text-31" class="widget widget_text">			<div class="textwidget"><p><a href="https://lynnwoodtoday.com/comments/">More recent comments</a></p>
</div>
		</aside><aside id="bs_zones-24" class="widget bs_zones"><div><broadstreet-zone zone-id="1489" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_multiple_zones-4" class="widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script></aside><aside id="bs_multiple_zones-5" class="widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script></aside><aside id="bs_zones-25" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="56629" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-26" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="65027" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-27" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="66393" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-38" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="80691" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-39" class="widget bs_zones"><div><broadstreet-zone zone-id="80692" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-29" class="widget bs_zones"><div><broadstreet-zone zone-id="72356" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-33" class="widget bs_zones"><div><broadstreet-zone zone-id="72356" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-30" class="widget bs_zones"><div><broadstreet-zone zone-id="72251" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-31" class="widget bs_zones"><div><broadstreet-zone zone-id="68224" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-57" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="68223" keywords="not_home_page,not_landing_page,is_article_page,county-government,county-human-rights-commission-seeks-nominations-for-2022-awards,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside>
            </div>

        </div><!-- .row -->

    </div><!-- Container end -->

</div><!-- Wrapper end -->


<div class="wrapper footer-area" id="wrapper-footer">

	<div class="footer-top-area">

		<div class="container">
			<div class="row">

				<div class="col-md-8 col-xs-12">
					<div class="footer-menu-area">
						<div class="menu-footer-menu-container"><ul id="footer-menu" class="menu"><li id="menu-item-93201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93201"><a href="https://lynnwoodtoday.com/commenting-policy/">Commenting Policy</a></li>
<li id="menu-item-93200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93200"><a href="https://lynnwoodtoday.com/our-policy-on-reproducing-content/">Our Policy on Reproducing Content</a></li>
<li id="menu-item-93202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93202"><a href="mailto:teresa@myedmondsnews.com">Submit News</a></li>
</ul></div>					</div>
				</div>

				<div class="col-md-4 col-xs-12">
					<div class="footer-social-icons">
						<a href="https://www.facebook.com/LynnwoodToday/" target="_blank"><i class="fa fa-facebook"></i></a>
						<a href="https://twitter.com/lynnwoodtoday" target="_blank"><i class="fa fa-twitter"></i></a>
						<a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
					</div>
				</div>

			</div>
		</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">

		<div class="container">
			<div class="row">

				<div class="col-md-6 col-xs-12">
					<div class="site-dev-info">
						<p>Website by <a href="https://webpublisherpro.com" target="_new">Web Publisher PRO</a></p>
					</div>
				</div>

				<div class="col-md-6 col-xs-12">
					<div class="site-info text-right">
						<p>&copy; Copyright 2022 | All rights reserved by <a class="site-name" href="https://lynnwoodtoday.com/" rel="home">Lynnwood Today</a></p>
					</div><!-- .site-info -->
				</div>

			</div>
		</div>

	</footer>

	<div class="scroll-up" style="display: block;">
        <i class="fa fa-angle-up"></i>
    </div>

</div><!-- wrapper end -->

</div><!-- #page -->

		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>        <script>
            var wordLimit = Number('300');
            jQuery(window).load(function () {
                jQuery('.form-group.comment-form-comment').append('<p class="comment_limit">' +
                    'Total: <span id="display_count">0</span> words. Words left: <span id="word_left">' + wordLimit + '</span></p>');
                jQuery('#subscribe-reloaded').attr('checked', 'checked');
                jQuery("#commentform").removeAttr("novalidate");
            });
            jQuery(document).ready(function () {
                jQuery("#comment").on('keyup', function () {
                    var words = this.value.match(/\S+/g).length;
                    if (words > wordLimit) {
                        var trimmed = jQuery(this).val().split(/\s+/, wordLimit).join(" ");
                        jQuery(this).val(trimmed + " ");
                    }
                    else {
                        jQuery('#display_count').text(words);
                        jQuery('#word_left').text(wordLimit - words);
                    }
                });
            });
        </script>
	<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><div id='pico-widget-container'></div><script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/lynnwoodtoday.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script src='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script src='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/wp-util.min.js' id='wp-util-js'></script>
<script type='text/javascript' id='themeplate-scripts-js-before'>
var trntoAjaxUrl='https://lynnwoodtoday.com/wp-admin/admin-ajax.php';
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/themes/toronto-pro/assets/js/theme.min.js' id='themeplate-scripts-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='//checkout.stripe.com/v2/checkout.js' id='stripe-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/sumo/sumoselect.js' id='wdp-sumoselect-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/maplace/maplace.js' id='maplace-js'></script>
<script type='text/javascript' id='wdp-frontend-script-js-extra'>
/* <![CDATA[ */
var wdp_checkout_params = {"key":"","label":"Pay For Claiming","amount":"20000","currency":"usd","name":"Lynnwood Today"};
/* ]]> */
</script>
<script type='text/javascript' id='wdp-frontend-script-js-before'>
var hideOnMobile = true;
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/js/frontend.js' id='wdp-frontend-script-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' defer src='https://lynnwoodtoday.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js' id='mc4wp-forms-api-js'></script>

</body>

</html>
