<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-title"
          content="Lynnwood Today - A news website covering all things Lynnwood, WA">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="https://lynnwoodtoday.com/xmlrpc.php">

    <title>Rep. Larsen to host COVID-19 telephone town hall April 7 - Lynnwood Today</title>

<!-- This site is optimized with the Yoast SEO plugin v13.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rep. Larsen to host COVID-19 telephone town hall April 7 - Lynnwood Today" />
<meta property="og:description" content="U.S. Rep. Rick Larsen will host a live telephone town hall Tuesday, April 7, to discuss the COVID-19 outbreak with 2nd District residents. Suzan “Suzi” LeVine, Commissioner of the Washington Employment Security Department, and Duane Fladland, Director of the Washington Small Business Development Center, will join Larsen to hear residents’ concerns and help answer questions..." />
<meta property="og:url" content="https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/" />
<meta property="og:site_name" content="Lynnwood Today" />
<meta property="article:section" content="COVID-19 Coronavirus" />
<meta property="article:published_time" content="2020-04-04T17:57:39+00:00" />
<meta property="og:image" content="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2020/02/larsen-211x300-1.jpg" />
<meta property="og:image:secure_url" content="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2020/02/larsen-211x300-1.jpg" />
<meta property="og:image:width" content="211" />
<meta property="og:image:height" content="300" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://lynnwoodtoday.com/#website","url":"https://lynnwoodtoday.com/","name":"Lynnwood Today","inLanguage":"en-US","description":"A news website covering all things Lynnwood, WA","potentialAction":[{"@type":"SearchAction","target":"https://lynnwoodtoday.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/#primaryimage","inLanguage":"en-US","url":"https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2020/02/larsen-211x300-1.jpg","width":211,"height":300},{"@type":"WebPage","@id":"https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/#webpage","url":"https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/","name":"Rep. Larsen to host COVID-19 telephone town hall April 7 - Lynnwood Today","isPartOf":{"@id":"https://lynnwoodtoday.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/#primaryimage"},"datePublished":"2020-04-04T17:57:39+00:00","dateModified":"2020-04-04T17:57:39+00:00","author":{"@id":"https://lynnwoodtoday.com/#/schema/person/9f4e3f838823f895d4f92decab74fd62"},"potentialAction":[{"@type":"ReadAction","target":["https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/"]}]},{"@type":["Person"],"@id":"https://lynnwoodtoday.com/#/schema/person/9f4e3f838823f895d4f92decab74fd62","name":"Administrator","image":{"@type":"ImageObject","@id":"https://lynnwoodtoday.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/cab918c5ec4286235c57e2e5242a9528?s=96&d=mm&r=g","caption":"Administrator"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//checkout.stripe.com' />
<link rel='dns-prefetch' href='//maps.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Feed" href="https://lynnwoodtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Comments Feed" href="https://lynnwoodtoday.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Lynnwood Today &raquo; iCal Feed" href="https://lynnwoodtoday.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Rep. Larsen to host COVID-19 telephone town hall April 7 Comments Feed" href="https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/lynnwoodtoday.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='dashicons-css'  href='https://lynnwoodtoday.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='https://lynnwoodtoday.com/wp-content/plugins/wunderground/assets/css/wunderground.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://lynnwoodtoday.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://lynnwoodtoday.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='if-menu-site-css-css'  href='https://lynnwoodtoday.com/wp-content/plugins/if-menu/assets/if-menu-site.css' type='text/css' media='all' />
<link rel='stylesheet' id='toronto-pro-css'  href='https://lynnwoodtoday.com/wp-content/themes/toronto-pro/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='themeplate-styles-css'  href='https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://lynnwoodtoday.com/wp-content/plugins/add-to-any/addtoany.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wdp-frontend-style-css'  href='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='decent-comments-widget-css'  href='https://lynnwoodtoday.com/wp-content/plugins/decent-comments/css/decent-comments-widget.css' type='text/css' media='all' />
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/ui/menu.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill.min.js'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/dom-ready.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/a11y.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/jquery/ui/autocomplete.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"6ee9f270f4","ajaxurl":"https:\/\/lynnwoodtoday.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/wunderground/assets/js/widget.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/add-to-any/addtoany.min.js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js'></script>
<script type='text/javascript' src='//maps.google.com/maps/api/js?sensor=false&#038;libraries=geometry%2Cplaces&#038;v=3.22&#038;key=AIzaSyCO7SPzdvnSSvGtkzKY_M7rnWZdddlrDh0&#038;ver=1.0.0'></script>
<link rel='https://api.w.org/' href='https://lynnwoodtoday.com/wp-json/' />
<link rel='shortlink' href='https://lynnwoodtoday.com/?p=102023' />
<link rel="alternate" type="application/json+oembed" href="https://lynnwoodtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flynnwoodtoday.com%2Frep-larsen-to-host-covid-19-telephone-town-hall-april-7%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://lynnwoodtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flynnwoodtoday.com%2Frep-larsen-to-host-covid-19-telephone-town-hall-april-7%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://lynnwoodtoday.com"><link rel="https://theeventscalendar.com/" href="https://lynnwoodtoday.com/wp-json/tribe/events/v1/" /><link rel="icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.category .page-header .page-title{
	font-size: 40px;
  text-transform: uppercase;
  color: #4db2ec;
}

@media only screen and (min-width: 960px) {
  .widget:not(.bs_zones){
		width:300px;
		margin-left: auto;
    margin-right: auto;
	}
	
}
.site-navigation ul li a{
	padding: 13px;
}		</style>
		
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-38313383-1"></script>
    <script>
        window.dataLayer = window.dataLayer || [];

        function gtag() {
            dataLayer.push(arguments);
        }

        gtag('js', new Date());

        gtag('config', 'UA-38313383-1');
    </script>

</head>

<body class="post-template-default single single-post postid-102023 single-format-standard wp-custom-logo tribe-no-js tribe-theme-parent-toronto-pro tribe-theme-child-lynnwood-child group-blog">

<div class="header-top-area">
    <div class="container">
        <div class="row">
            <div class="col-md-10 col-xs-12">
                <div class="top-menu-area">
                    <div class="top-nav-item">
                        <p>Saturday, April 4, 2020</p>
                    </div>
                    <div class="top-nav-item">
                        <div class="menu-header-eyebrow-menu-container"><ul id="menu-header-eyebrow-menu" class="menu"><li id="menu-item-93293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93293"><a href="https://mltnews.com">MLTNEWS</a></li>
<li id="menu-item-93294" class="active-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-93294"><a href="https://lynnwoodtoday.com">LYNNWOOD TODAY</a></li>
<li id="menu-item-93295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93295"><a href="https://myedmondsnews.com">MY EDMONDS NEWS</a></li>
<li id="menu-item-93296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93296"><a href="https://myneighbornewsnetwork.com/">MY NEIGHBORHOOD NEWS NETWORK</a></li>
</ul></div>                    </div>
                </div>
            </div>
            <div class="col-md-2 col-xs-12">
                <div class="footer-social-icons">
                    <a href="https://facebook.com/lynnwoodtoday" target="_blank"><i class="fa fa-facebook"></i></a>
                    <a href="https://twitter.com/lynnwoodtoday" target="_blank"><i class="fa fa-twitter"></i></a>
                    <a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
                </div>
            </div>
        </div>
    </div>
</div>

<div id="page" class="hfeed site">

    <!--    banner top add-->
                <div class="top-add-module text-center">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">
                        <div id="custom_html-5" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1487"></broadstreet-zone></div></div>                    </div>
                </div>
            </div>
        </div>
    
    <!-- ******************* navigation area ******************* -->
    <div class="wrapper-fluid wrapper-navbar" id="wrapper-navbar">

        <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

        <div class="header-area hidden-xs hidden-sm">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">

                        <div class="header-logo-area">
                            <a class="navbar-brand" href="https://lynnwoodtoday.com/"
                               title="Lynnwood Today" rel="home">
                                <img src="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/10/lynwood-today-logo.png"
                                     srcset="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/10/lynwood-today-logo1.png 1x, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/10/lynwood-today-logo2.png 2x"
                                     alt="Lynnwood Today">
                            </a>
                            <!--							<span class="site-tagline hidden-xs">Powered by -->
                            <!--</span>-->
                        </div>

                        <div class="header-search-box pull-right">
                            <a href="#"><i class="fa fa-search"></i></a>
                            <form method="get" action="https://lynnwoodtoday.com" class="header-search-form"
                                  role="search">
                                <input name="s" id="search-input" class="search-field form-control" placeholder="Search"
                                       required="" value="" type="search" autofocus>
                                <button type="submit"><i class="fa fa-search"></i></button>
                                <input type="hidden" name="post_type" value="post">
                            </form>
                        </div>

                        <div class="header-sub-menu-area pull-right">
                            <!-- The WordPress Menu goes here -->
                            <div class="menu-sub-menu-container"><ul id="sub-menu" class="menu"><li id="menu-item-93217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93217"><a href="https://lynnwoodtoday.com/about/">About <i class="fa fa-angle-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-93218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93218"><a href="https://lynnwoodtoday.com/w-video-studio/">W Video Studio</a></li>
	<li id="menu-item-93219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93219"><a href="https://lynnwoodtoday.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li id="menu-item-93283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93283"><a href="https://lynnwoodtoday.com/advertise/">Advertise <i class="fa fa-angle-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-93250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93250"><a href="https://lynnwoodtoday.com/lynnwood-today-sponsors/">Our Advertisers</a></li>
</ul>
</li>
<li id="menu-item-93221" class="sub-menu-support-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-93221"><a href="https://lynnwoodtoday.com/membership/">Support Us</a></li>
</ul></div>                        </div>

                    </div>
                </div>
            </div>
        </div>

        <nav class="site-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

            <div class="navbar">

                <div class="container">

                    <div class="row">

                        <div class="col-md-12">

                            <div class="navbar-header">

                                <!-- .navbar-toggle is used as the toggle for collapsed navbar content -->
                                <button type="button" class="navbar-toggle" data-toggle="collapse"
                                        data-target=".navbar-responsive-collapse">
                                    <span class="sr-only">Toggle navigation</span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                </button>

                                <!-- Your site title as branding in the menu -->
                                <a class="navbar-brand hidden-md hidden-lg" href="https://lynnwoodtoday.com/"
                                   title="Lynnwood Today" rel="home">
                                    <img src="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/10/lynwood-today-logo.png"
                                         srcset="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/10/lynwood-today-logo1.png 1x, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/10/lynwood-today-logo2.png 2x"
                                         alt="Lynnwood Today">
                                </a>
                                <span class="site-tagline-mobile">Powered by Lynnwood Today</span>

                            </div>

                            <!-- The WordPress Menu goes here -->
                            <div class="collapse navbar-collapse navbar-responsive-collapse pull-left"><ul id="main-menu" class="nav navbar-nav"><li id="menu-item-101330" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent nav-item menu-item-101330"><a title="COVID-19" href="https://lynnwoodtoday.com/category/health-and-fitness/covid-19-coronavirus/">COVID-19</a></li>
<li id="menu-item-93278" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93278"><a title="Obituaries" href="https://lynnwoodtoday.com/obituaries/">Obituaries</a></li>
<li id="menu-item-85924" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-85924"><a title="EAT / PLAY / LIVE" href="https://lynnwoodtoday.com/eat-live-play/">EAT / PLAY / LIVE</a></li>
<li id="menu-item-93252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children nav-item menu-item-93252 dropdown"><a title="Events" href="/events/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-93257" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-93257"><a title="Submit Event" href="/events/community/add">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-85188" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-85188"><a title="Health &#038; Fitness" href="https://lynnwoodtoday.com/health-fitness/">Health &#038; Fitness</a></li>
<li id="menu-item-76759" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-76759"><a title="Home &#038; Real Estate" href="https://lynnwoodtoday.com/home-real-estate/">Home &#038; Real Estate</a></li>
<li id="menu-item-93279" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93279"><a title="Sound Silver Living" href="https://lynnwoodtoday.com/sound-silver-living/">Sound Silver Living</a></li>
<li id="menu-item-101925" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-101925"><a title="Support Local" href="https://myedmondsnews.com/support-local/">Support Local</a></li>
<li class="pc-search-for-mobile"><form method="get" action="https://lynnwoodtoday.com" class="header-search-form" role="search"><input name="s" id="search-input" class="search-field form-control" placeholder="Search" required="" value="" type="search" autofocus><button type="submit"><i class="fa fa-search"></i></button><input type="hidden" name="post_type" value="post"></form></li></ul></div>
                        </div> <!-- .col-md-11 or col-md-12 end -->

                    </div> <!-- .row end -->

                </div> <!-- .container -->

            </div><!-- .navbar -->

        </nav><!-- .site-navigation -->
                    <nav class="trnto-secondary-menu visible-lg-block visible-md-block">
                <div class="container">
                    <div class="row">
                        <div class="col-md-12">
                            <div class="menu-secondary-menu-container"><ul id="secondary-menu" class="nav navbar-nav"><li id="menu-item-93280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children nav-item menu-item-93280 dropdown"><a title="Columns" href="https://lynnwoodtoday.com/category/columns/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Columns <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-95279" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-95279"><a title="Day Trip Discoveries" href="https://lynnwoodtoday.com/category/columns/day-trip-discoveries/">Day Trip Discoveries</a></li>
	<li id="menu-item-95281" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95281"><a title="Fitness Corner" href="https://lynnwoodtoday.com/category/columns/fitness-corner/">Fitness Corner</a></li>
	<li id="menu-item-95282" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95282"><a title="Forward Thinking" href="https://lynnwoodtoday.com/category/columns/forward-thinking/">Forward Thinking</a></li>
	<li id="menu-item-95284" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95284"><a title="Healthy Eating" href="https://lynnwoodtoday.com/category/health-and-fitness/healthy-eating/">Healthy Eating</a></li>
	<li id="menu-item-95286" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95286"><a title="Just Around the Corner" href="https://lynnwoodtoday.com/category/just-around-the-corner/">Just Around the Corner</a></li>
	<li id="menu-item-95292" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95292"><a title="Looking Back" href="https://lynnwoodtoday.com/category/looking-back/">Looking Back</a></li>
	<li id="menu-item-95293" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95293"><a title="Lynnwood Lifestyles" href="https://lynnwoodtoday.com/category/columns/lynnwood-lifestyles/">Lynnwood Lifestyles</a></li>
	<li id="menu-item-95294" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95294"><a title="Playtime" href="https://lynnwoodtoday.com/category/columns/playtime/">Playtime</a></li>
	<li id="menu-item-95295" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95295"><a title="Recommended Reads" href="https://lynnwoodtoday.com/category/columns/recommended-reads/">Recommended Reads</a></li>
	<li id="menu-item-95296" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95296"><a title="Restaurant News" href="https://lynnwoodtoday.com/category/columns/restaurant-news/">Restaurant News</a></li>
	<li id="menu-item-95297" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95297"><a title="Service Club Corner" href="https://lynnwoodtoday.com/category/service-club-corner/">Service Club Corner</a></li>
	<li id="menu-item-95291" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95291"><a title="Kids are Bookin&#039; It" href="https://lynnwoodtoday.com/category/kids-are-bookin-it/">Kids are Bookin&#8217; It</a></li>
</ul>
</li>
<li id="menu-item-93194" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93194"><a title="Photos" href="https://lynnwoodtoday.com/category/photos-2/">Photos</a></li>
<li id="menu-item-93196" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93196"><a title="Public Safety" href="https://lynnwoodtoday.com/category/public-safety-2/">Public Safety</a></li>
<li id="menu-item-93281" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93281"><a title="Schools" href="https://lynnwoodtoday.com/category/schools/">Schools</a></li>
<li id="menu-item-93197" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93197"><a title="Sports" href="https://lynnwoodtoday.com/category/sports-2/">Sports</a></li>
<li id="menu-item-93282" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93282"><a title="Marketing Services" href="https://lynnwoodtoday.com/business-resources-kaufer-dmc/">Marketing Services</a></li>
</ul></div>                        </div>
                    </div>
                </div>
            </nav>
        
        
    </div><!-- .wrapper-navbar end -->

<div class="wrapper" id="single-wrapper">

	<div id="content" class="container">

		<div class="row">

			<div id="primary"
			     class="col-md-8 content-area">

				<main id="main" class="site-main" role="main">

					
					
<article id="post-102023" class="post-102023 post type-post status-publish format-standard has-post-thumbnail hentry category-covid-19-coronavirus category-federal-government">

	
	<header class="entry-header">
		<h2 class="entry-title">Rep. Larsen to host COVID-19 telephone town hall April 7</h2>
		
		<div class="entry-meta">
			
			<span class="posted-on">10 mins ago </span><span class="post-views"><i class="fa fa-eye"></i> 4 </span>		</div>

	</header><!-- .entry-header -->

	<div class="entry-content">
		<p><span style="font-weight: 400;"><a href="https://dpa730eaqha29.cloudfront.net/mltnews/wp-content/uploads/2020/02/larsen-211x300.jpg"><img class=" wp-image-99511 alignleft" src="https://dpa730eaqha29.cloudfront.net/mltnews/wp-content/uploads/2020/02/larsen-211x300-211x300.jpg" alt="" width="167" height="237" /></a>U.S. Rep. Rick Larsen will host a live telephone town hall Tuesday, April 7, to discuss the COVID-19 outbreak with 2nd District residents.</span></p>
<p><span style="font-weight: 400;">Suzan “Suzi” LeVine, Commissioner of the Washington Employment Security Department, and Duane Fladland, Director of the Washington Small Business Development Center, will join Larsen to hear residents’ concerns and help answer questions about benefits available to workers and small businesses suffering from the virus’ impacts.</span></p>
<p><span style="font-weight: 400;">Last month, Larsen </span><strong><a href="https://www.youtube.com/watch?v=FDHSZ50mafc">hosted a COVID-19 telephone town hall</a></strong><span style="font-weight: 400;"> with Dr. Paul Pottinger, Director of the Infectious Diseases and Tropical Medicine Clinic at the University of Washington Medical Center. This year, Larsen has held public forums in Mountlake Terrace, Sedro-Woolley, Bow, Clinton, Stanwood, Brier, Eastsound, Oak Harbor and Anacortes.</span></p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://lynnwoodtoday.com/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/" data-a2a-title="Rep. Larsen to host COVID-19 telephone town hall April 7"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Flynnwoodtoday.com%2Frep-larsen-to-host-covid-19-telephone-town-hall-april-7%2F&amp;linkname=Rep.%20Larsen%20to%20host%20COVID-19%20telephone%20town%20hall%20April%207" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Flynnwoodtoday.com%2Frep-larsen-to-host-covid-19-telephone-town-hall-april-7%2F&amp;linkname=Rep.%20Larsen%20to%20host%20COVID-19%20telephone%20town%20hall%20April%207" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Flynnwoodtoday.com%2Frep-larsen-to-host-covid-19-telephone-town-hall-april-7%2F&amp;linkname=Rep.%20Larsen%20to%20host%20COVID-19%20telephone%20town%20hall%20April%207" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Flynnwoodtoday.com%2Frep-larsen-to-host-covid-19-telephone-town-hall-april-7%2F&amp;linkname=Rep.%20Larsen%20to%20host%20COVID-19%20telephone%20town%20hall%20April%207" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>	</div><!-- .entry-content -->

	<footer class="entry-footer"></footer><!-- .entry-footer -->

	
</article><!-- #post-## -->


											
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rep-larsen-to-host-covid-19-telephone-town-hall-april-7/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://lynnwoodtoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="form-group comment-form-comment">
    <label for="comment">Comment <span class="required">*</span></label>
    <textarea class="form-control" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
    </div><div class="form-group comment-form-author"><label for="author">Name <span class="required">*</span></label> <input class="form-control" id="author" name="author" type="text" value="" size="30" aria-required='true' /></div>
<div class="form-group comment-form-email"><label for="email">Email <span class="required">*</span></label> <input class="form-control" id="email" name="email" type="email" value="" size="30" aria-required='true' /></div>
<div class="form-group comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30" /></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='102023' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9f6e6fbaa8" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="134"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
										<!-- add subscribe from -->
					<div class="subscribe-panel">

	<h3 class="subscribe-heading">Lynnwood Today</h3>
	<p><strong>Sign Up for Our Daily Lynnwood Newsletter</strong></p>

	<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.5 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-71903 mc4wp-form-theme mc4wp-form-theme-red" method="post" data-id="71903" data-name="Newsletter" ><div class="mc4wp-form-fields"><div class="subscribe-form">
	<input type="email" name="EMAIL" placeholder="Your email address" required /> <input type="submit" value="Sign up" />
</div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1586023659" /><input type="hidden" name="_mc4wp_form_id" value="71903" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin -->
</div>

					<section class="related-posts-area">
						<!-- <h4 class="related-posts-area-heading">--><!--</h4>-->

						
						<div class="trnto-next-post-nav" data-id="102030"></div>

						
					</section>

					<div class="back-to-home text-center">
						<a href="https://lynnwoodtoday.com">BACK TO HOME</a>
					</div>

				</main><!-- #main -->

			</div><!-- #primary -->

			<div id="secondary" class="col-md-4 widget-area hidden-xs hidden-sm single-post-sidebar"
			     role="complementary">

				<aside id="bs_zones-22" class="widget bs_zones"><div><broadstreet-zone zone-id="32659" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-21" class="widget bs_zones"><div><broadstreet-zone zone-id="48295" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="decent_comments_widget-3" class="widget widget_decent_comments_widget"><h3 class="widget-title">Recent Comments</h3><div class="decent-comments"><ul><li><div class="comment"><span class="comment-author">Administrator</span><span class="comment-date"> Apr 4, 2020 at 11:06 am</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/directory-of-lynnwood-restaurants-offering-takeout-delivery/#comment-26357">Updated April 3: Directory of Lynnwood restaurants offering takeout, delivery</a></span><span class="comment-excerpt">They are closed until further notice. We will add that to the list. </span></div></li><li><div class="comment"><span class="comment-author">Susan holcomb</span><span class="comment-date"> Apr 3, 2020 at 3:00 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/free-emergency-dental-work-to-be-offered-weekly-in-lynnwood-starting-april-2/#comment-26346">Free emergency dental work to be offered weekly in Lynnwood starting April 2</a></span><span class="comment-excerpt">Have a friend w out a job that needs this. Glad ppl r respond DC ing to this need </span></div></li><li><div class="comment"><span class="comment-author">Jack Hartsock</span><span class="comment-date"> Apr 3, 2020 at 2:46 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/directory-of-lynnwood-restaurants-offering-takeout-delivery/#comment-26345">Updated April 3: Directory of Lynnwood restaurants offering takeout, delivery</a></span><span class="comment-excerpt">Any word on Cafe India off 44th Ave W? </span></div></li><li><div class="comment"><span class="comment-author">Betty Lou Gaeng</span><span class="comment-date"> Apr 3, 2020 at 1:21 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/looking-back-before-lynnwood-the-stump-farms-of-alderwood-manor/#comment-26344">Looking Back: Before Lynnwood &#8212; the stump farms of Alderwood Manor</a></span><span class="comment-excerpt">Mike -- I started first grade with Dale at Alderwood Manor Grade School in 1933. </span></div></li><li><div class="comment"><span class="comment-author">mike echelbarger</span><span class="comment-date"> Apr 3, 2020 at 12:35 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/looking-back-before-lynnwood-the-stump-farms-of-alderwood-manor/#comment-26343">Looking Back: Before Lynnwood &#8212; the stump farms of Alderwood Manor</a></span><span class="comment-excerpt">As a kid growing up in Alderwood in the 1950s there were plenty of stumps around but not many as</span></div></li></ul></div></aside><aside id="text-31" class="widget widget_text">			<div class="textwidget"><p><a href="https://lynnwoodtoday.com/comments/">More recent comments</a></p>
</div>
		</aside><aside id="bs_zones-24" class="widget bs_zones"><div><broadstreet-zone zone-id="1489" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_multiple_zones-4" class="widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script></aside><aside id="bs_multiple_zones-5" class="widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script></aside><aside id="bs_zones-25" class="widget bs_zones"><div><broadstreet-zone zone-id="56629" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-26" class="widget bs_zones"><div><broadstreet-zone zone-id="65027" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-27" class="widget bs_zones"><div><broadstreet-zone zone-id="66393" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-29" class="widget bs_zones"><div><broadstreet-zone zone-id="72356" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-33" class="widget bs_zones"><div><broadstreet-zone zone-id="72356" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-30" class="widget bs_zones"><div><broadstreet-zone zone-id="72251" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-31" class="widget bs_zones"><div><broadstreet-zone zone-id="68224" keywords="not_home_page,not_landing_page,is_article_page,covid-19-coronavirus,health-and-fitness,federal-government,rep-larsen-to-host-covid-19-telephone-town-hall-april-7,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside>
			</div>

		</div><!-- .row -->

	</div><!-- Container end -->

</div><!-- Wrapper end -->


<div class="wrapper footer-area" id="wrapper-footer">

	<div class="footer-top-area">

		<div class="container">
			<div class="row">

				<div class="col-md-8 col-xs-12">
					<div class="footer-menu-area">
						<div class="menu-footer-menu-container"><ul id="footer-menu" class="menu"><li id="menu-item-93201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93201"><a href="https://lynnwoodtoday.com/commenting-policy/">Commenting Policy</a></li>
<li id="menu-item-93200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93200"><a href="https://lynnwoodtoday.com/our-policy-on-reproducing-content/">Our Policy on Reproducing Content</a></li>
<li id="menu-item-93199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93199"><a href="https://lynnwoodtoday.com/submit-community-news/">Submit Community News</a></li>
<li id="menu-item-93202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93202"><a href="mailto:lynnwoodtodayeditor@gmail.com">Submit News</a></li>
</ul></div>					</div>
				</div>

				<div class="col-md-4 col-xs-12">
					<div class="footer-social-icons">
						<a href="https://www.facebook.com/LynnwoodToday/" target="_blank"><i class="fa fa-facebook"></i></a>
						<a href="https://twitter.com/lynnwoodtoday" target="_blank"><i class="fa fa-twitter"></i></a>
						<a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
					</div>
				</div>

			</div>
		</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">

		<div class="container">
			<div class="row">

				<div class="col-md-6 col-xs-12">
					<div class="site-dev-info">
						<p>Website by <a href="https://webpublisherpro.com" target="_new">Web Publisher PRO</a></p>
					</div>
				</div>

				<div class="col-md-6 col-xs-12">
					<div class="site-info text-right">
						<p>&copy; Copyright 2020 | All rights reserved by <a class="site-name" href="https://lynnwoodtoday.com/" rel="home">Lynnwood Today</a></p>
					</div><!-- .site-info -->
				</div>

			</div>
		</div>

	</footer>

	<div class="scroll-up" style="display: block;">
        <i class="fa fa-angle-up"></i>
    </div>

</div><!-- wrapper end -->

</div><!-- #page -->

<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','covid-19-coronavirus','health-and-fitness','federal-government','rep-larsen-to-host-covid-19-telephone-town-hall-april-7','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["covid-19-coronavirus","health-and-fitness","federal-government","rep-larsen-to-host-covid-19-telephone-town-hall-april-7","post"],"url":"rep-larsen-to-host-covid-19-telephone-town-hall-april-7"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(525);
 });</script>		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script src='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/underscore.min.js'></script>
<script src='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/wp-util.min.js'></script>
<script type='text/javascript'>
var trntoAjaxUrl='https://lynnwoodtoday.com/wp-admin/admin-ajax.php';
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/themes/toronto-pro/assets/js/theme.min.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='//checkout.stripe.com/v2/checkout.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/sumo/sumoselect.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/maplace/maplace.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wdp_checkout_params = {"key":"","label":"Pay For Claiming","amount":"20000","currency":"usd","name":"Lynnwood Today"};
/* ]]> */
</script>
<script type='text/javascript'>
var hideOnMobile = true;
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/js/frontend.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.min.js'></script>

</body>

</html>
