<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-title"
          content="Lynnwood Today - A news website covering all things Lynnwood, WA">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="https://lynnwoodtoday.com/xmlrpc.php">

    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Edmonds School Board hears pleas for improved safety in district&#039;s schools - Lynnwood Today</title>
	<link rel="canonical" href="https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Edmonds School Board hears pleas for improved safety in district&#039;s schools - Lynnwood Today" />
	<meta property="og:description" content="School safety was the main concern raised by public commenters at the Edmonds School District Board of Directors meeting Tuesday, Nov. 8. Many commenters said their concerns stemmed not only from the Tuesday morning shooting at Seattle’s Ingraham High School that killed one student, but also from a recent incident where a gun was found..." />
	<meta property="og:url" content="https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/" />
	<meta property="og:site_name" content="Lynnwood Today" />
	<meta property="article:published_time" content="2022-11-11T02:38:43+00:00" />
	<meta property="article:modified_time" content="2022-11-11T02:40:50+00:00" />
	<meta property="og:image" content="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382.png" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="576" />
	<meta property="og:image:type" content="image/png" />
	<meta name="author" content="Administrator" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Administrator" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://lynnwoodtoday.com/#website","url":"https://lynnwoodtoday.com/","name":"Lynnwood Today","description":"A news website covering all things Lynnwood, WA","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://lynnwoodtoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/#primaryimage","url":"https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382.png","contentUrl":"https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382.png","width":1024,"height":576},{"@type":"WebPage","@id":"https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/#webpage","url":"https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/","name":"Edmonds School Board hears pleas for improved safety in district's schools - Lynnwood Today","isPartOf":{"@id":"https://lynnwoodtoday.com/#website"},"primaryImageOfPage":{"@id":"https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/#primaryimage"},"datePublished":"2022-11-11T02:38:43+00:00","dateModified":"2022-11-11T02:40:50+00:00","author":{"@id":"https://lynnwoodtoday.com/#/schema/person/9f4e3f838823f895d4f92decab74fd62"},"breadcrumb":{"@id":"https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/"]}]},{"@type":"BreadcrumbList","@id":"https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://lynnwoodtoday.com/"},{"@type":"ListItem","position":2,"name":"Edmonds School Board hears pleas for improved safety in district&#8217;s schools"}]},{"@type":"Person","@id":"https://lynnwoodtoday.com/#/schema/person/9f4e3f838823f895d4f92decab74fd62","name":"Administrator","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://lynnwoodtoday.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/cab918c5ec4286235c57e2e5242a9528?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/cab918c5ec4286235c57e2e5242a9528?s=96&d=mm&r=g","caption":"Administrator"},"url":"https://lynnwoodtoday.com/author/teresa-wippel/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdn.streetinteractive.com' />
<link rel='dns-prefetch' href='//checkout.stripe.com' />
<link rel='dns-prefetch' href='//maps.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Feed" href="https://lynnwoodtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Comments Feed" href="https://lynnwoodtoday.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Lynnwood Today &raquo; iCal Feed" href="https://lynnwoodtoday.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Lynnwood Today &raquo; Edmonds School Board hears pleas for improved safety in district&#8217;s schools Comments Feed" href="https://lynnwoodtoday.com/school-board-hears-pleas-for-improved-safety-in-districts-schools/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/lynnwoodtoday.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='dashicons-css'  href='https://lynnwoodtoday.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='https://lynnwoodtoday.com/wp-content/plugins/wunderground/assets/css/wunderground.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css'  href='https://lynnwoodtoday.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-mini-calendar-block.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://lynnwoodtoday.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://lynnwoodtoday.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.css' type='text/css' media='all' />
<link rel='stylesheet' id='if-menu-site-css-css'  href='https://lynnwoodtoday.com/wp-content/plugins/if-menu/assets/if-menu-site.css' type='text/css' media='all' />
<link rel='stylesheet' id='toronto-pro-css'  href='https://lynnwoodtoday.com/wp-content/themes/toronto-pro/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='themeplate-styles-css'  href='https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='wdp-frontend-style-css'  href='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='decent-comments-widget-css'  href='https://lynnwoodtoday.com/wp-content/plugins/decent-comments/css/decent-comments-widget.css' type='text/css' media='all' />
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery/jquery-1.12.4-wp.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-migrate/jquery-migrate-1.4.1-wp.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/widget.min.js' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/position.min.js' id='jquery-ui-position-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' id='wunderground-widget-js-extra'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"86b154b59e","ajaxurl":"https:\/\/lynnwoodtoday.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/wunderground/assets/js/widget.min.js' id='wunderground-widget-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.streetinteractive.com/init-2.min.js?v=1.44.0&#038;ver=5.8.6' id='broadstreet-cdn-js'></script>
<script type='text/javascript' id='read-more.js-js-extra'>
/* <![CDATA[ */
var pp_vars = {"publisher_id":"1889daee-a7bd-47be-b7c7-cbd985d6be31","widget_endpoint":"https:\/\/gadget.pico.tools","plugin_version":"1.0.2","widget_version":"11.11.22.05.15","pico_context":"gadget","post_id":"137196","post_type":"post","post_title":"Edmonds School Board hears pleas for improved safety in district's schools","taxonomies_for_this_post_type":["category","post_tag","post_format"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","wp_theme","wpcode_type","wpcode_location","wpcode_tags","tribe_events_cat","restaurant_category"],"show_read_more_button":"1","taxonomies":{"category":["education"]},"resource_ref":"name=school-board-hears-pleas-for-improved-safety-in-districts-schools"};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/pico/includes/js/read-more.js' id='read-more.js-js'></script>
<script type='text/javascript' src='//maps.google.com/maps/api/js?sensor=false&#038;libraries=geometry%2Cplaces&#038;v=3.22&#038;key=AIzaSyA0BD9Xwz_Fk_Q2bqDKMqa3xMs6StV0cjM&#038;ver=1.0.0' id='google-map-js'></script>
<link rel="https://api.w.org/" href="https://lynnwoodtoday.com/wp-json/" /><link rel="alternate" type="application/json" href="https://lynnwoodtoday.com/wp-json/wp/v2/posts/137196" /><link rel='shortlink' href='https://lynnwoodtoday.com/?p=137196' />
<link rel="alternate" type="application/json+oembed" href="https://lynnwoodtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flynnwoodtoday.com%2Fschool-board-hears-pleas-for-improved-safety-in-districts-schools%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://lynnwoodtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flynnwoodtoday.com%2Fschool-board-hears-pleas-for-improved-safety-in-districts-schools%2F&#038;format=xml" />
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','education','school-board-hears-pleas-for-improved-safety-in-districts-schools','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["education","school-board-hears-pleas-for-improved-safety-in-districts-schools","post"],"url":"school-board-hears-pleas-for-improved-safety-in-districts-schools"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(525, { domain: 'partner.streetinteractive.com'});
 });</script><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-BCEFNZMCNX"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-BCEFNZMCNX');
</script><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://lynnwoodtoday.com"><link rel="alternate" href="https://lynnwoodtoday.com/wp-json/tribe/events/v1/" />
        <script type="text/javascript">
            var jQueryMigrateHelperHasSentDowngrade = false;

			window.onerror = function( msg, url, line, col, error ) {
				// Break out early, do not processing if a downgrade reqeust was already sent.
				if ( jQueryMigrateHelperHasSentDowngrade ) {
					return true;
                }

				var xhr = new XMLHttpRequest();
				var nonce = '78b7754aec';
				var jQueryFunctions = [
					'andSelf',
					'browser',
					'live',
					'boxModel',
					'support.boxModel',
					'size',
					'swap',
					'clean',
					'sub',
                ];
				var match_pattern = /\)\.(.+?) is not a function/;
                var erroredFunction = msg.match( match_pattern );

                // If there was no matching functions, do not try to downgrade.
                if ( typeof erroredFunction !== 'object' || typeof erroredFunction[1] === "undefined" || -1 === jQueryFunctions.indexOf( erroredFunction[1] ) ) {
                    return true;
                }

                // Set that we've now attempted a downgrade request.
                jQueryMigrateHelperHasSentDowngrade = true;

				xhr.open( 'POST', 'https://lynnwoodtoday.com/wp-admin/admin-ajax.php' );
				xhr.setRequestHeader( 'Content-Type', 'application/x-www-form-urlencoded' );
				xhr.onload = function () {
					var response,
                        reload = false;

					if ( 200 === xhr.status ) {
                        try {
                        	response = JSON.parse( xhr.response );

                        	reload = response.data.reload;
                        } catch ( e ) {
                        	reload = false;
                        }
                    }

					// Automatically reload the page if a deprecation caused an automatic downgrade, ensure visitors get the best possible experience.
					if ( reload ) {
						location.reload();
                    }
				};

				xhr.send( encodeURI( 'action=jquery-migrate-downgrade-version&_wpnonce=' + nonce ) );

				// Suppress error alerts in older browsers
				return true;
			}
        </script>

		<link rel="icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2019/12/cropped-lynnwood-today-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			.category .page-header .page-title{
	font-size: 40px;
  text-transform: uppercase;
  color: #4db2ec;
}

@media only screen and (min-width: 960px) {
  .widget:not(.bs_zones){
		width:300px;
		margin-left: auto;
    margin-right: auto;
	}
	
}
.site-navigation ul li a{
	padding: 13px;
}
.show-street-dialog .container {
    width: inherit;
}
.support-main a {
    border: none;
    box-shadow: none;
    color: #fff;
    background: #074d81;
    font-size: 15px;
    padding: 3px 5px;
    text-shadow: none;
    border-radius: 3px;
    margin-bottom: 10px;
    display: inline-block;
    margin-right: 5px;
}
.decent-comments .comment-excerpt {
    word-break: break-word;
}

.banner-btm-ad .container {
	width: 100% important;
}		</style>
		
    <!-- Global site tag (gtag.js) - Google Analytics -->
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-38313383-1"></script>
    <script>
        window.dataLayer = window.dataLayer || [];

        function gtag() {
            dataLayer.push(arguments);
        }

        gtag('js', new Date());

        gtag('config', 'UA-38313383-1');
    </script>

</head>

<body class="post-template-default single single-post postid-137196 single-format-standard wp-custom-logo tribe-no-js tribe-theme-parent-toronto-pro tribe-theme-child-lynnwood-child group-blog">

<div class="header-top-area">
    <div class="container">
        <div class="row">
            <div class="col-md-10 col-xs-12">
                <div class="top-menu-area">
                    <div class="top-nav-item">
                        <p>Thursday, November 10, 2022</p>
                    </div>
                    <div class="top-nav-item">
                        <div class="menu-header-eyebrow-menu-container"><ul id="menu-header-eyebrow-menu" class="menu"><li id="menu-item-93293" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93293"><a href="https://mltnews.com">MLTNEWS</a></li>
<li id="menu-item-93294" class="active-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-93294"><a href="https://lynnwoodtoday.com">LYNNWOOD TODAY</a></li>
<li id="menu-item-93295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93295"><a href="https://myedmondsnews.com">MY EDMONDS NEWS</a></li>
<li id="menu-item-93296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93296"><a href="https://myneighbornewsnetwork.com/">MY NEIGHBORHOOD NEWS NETWORK</a></li>
</ul></div>                    </div>
                </div>
            </div>
            <div class="col-md-2 col-xs-12">
                <div class="footer-social-icons">
                    <a href="https://facebook.com/lynnwoodtoday" target="_blank"><i class="fa fa-facebook"></i></a>
                    <a href="https://twitter.com/lynnwoodtoday" target="_blank"><i class="fa fa-twitter"></i></a>
                    <a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
                </div>
            </div>
        </div>
    </div>
</div>

<div id="page" class="hfeed site">

    <div class="mobile-membership-btn-area text-center visible-xs">
        <a class="membership-btn" href="https://lynnwoodtoday.com/membership/">Become A Supporter</a>
    </div>

    <!--    banner top add-->
                <div class="top-add-module text-center">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">
                        <div id="custom_html-5" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><broadstreet-zone zone-id="1487"></broadstreet-zone></div></div>                    </div>
                </div>
            </div>
        </div>
    
    <!-- ******************* navigation area ******************* -->
    <div class="wrapper-fluid wrapper-navbar" id="wrapper-navbar">

        <a class="skip-link screen-reader-text" href="#content">Skip to content</a>
        <div class="header-area hidden-xs hidden-sm">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">

                        <div class="header-logo-area">
                            <a class="navbar-brand" href="https://lynnwoodtoday.com/"
                               title="Lynnwood Today" rel="home">
                                <img src="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2021/04/Lynnwood-Today-Picton-Blue-Logo-Transparent-1.png"
                                     srcset="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2021/04/Lynnwood-Today-Picton-Blue-Logo-Transparent-1.png 1x, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2021/04/Lynnwood-Today-Picton-Blue-Logo-Transparent-1.png 2x"
                                     alt="Lynnwood Today">
                            </a>
                            <!--							<span class="site-tagline hidden-xs">Powered by -->
                            <!--</span>-->
                        </div>

                        <div class="header-search-box pull-right">
                            <a href="#"><i class="fa fa-search"></i></a>
                            <form method="get" action="https://lynnwoodtoday.com" class="header-search-form"
                                  role="search">
                                <input name="s" id="search-input" class="search-field form-control" placeholder="Search"
                                       required="" value="" type="search" autofocus>
                                <button type="submit"><i class="fa fa-search"></i></button>
                                <input type="hidden" name="post_type" value="post">
                            </form>
                        </div>

                        <div class="header-sub-menu-area pull-right">
                            <!-- The WordPress Menu goes here -->
                            <div class="menu-sub-menu-container"><ul id="sub-menu" class="menu"><li id="menu-item-93217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93217"><a href="https://lynnwoodtoday.com/about/">About <i class="fa fa-angle-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-124326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124326"><a href="https://lynnwoodtoday.com/about/">Lynnwood Today</a></li>
	<li id="menu-item-93218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93218"><a href="https://lynnwoodtoday.com/w-video-studio/">W Video Studio</a></li>
	<li id="menu-item-93219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93219"><a href="https://lynnwoodtoday.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li id="menu-item-93283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93283"><a href="https://lynnwoodtoday.com/advertise/">Advertise</a></li>
<li id="menu-item-93221" class="sub-menu-support-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-93221"><a href="https://lynnwoodtoday.com/membership/">Support Us</a></li>
</ul></div>                        </div>

                    </div>
                </div>
            </div>
        </div>

        <nav class="site-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

            <div class="navbar">

                <div class="container">

                    <div class="row">

                        <div class="col-md-12">

                            <div class="navbar-header">

                                <!-- .navbar-toggle is used as the toggle for collapsed navbar content -->
                                <button type="button" class="navbar-toggle" data-toggle="collapse"
                                        data-target=".navbar-responsive-collapse">
                                    <span class="sr-only">Toggle navigation</span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                    <span class="icon-bar"></span>
                                </button>

                                <!-- Your site title as branding in the menu -->
                                <a class="navbar-brand hidden-md hidden-lg" href="https://lynnwoodtoday.com/"
                                   title="Lynnwood Today" rel="home">
                                    <img src="https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/images/logo-white.png"
                                         srcset="https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/images/logo-white.png, https://lynnwoodtoday.com/wp-content/themes/lynnwood-child/assets/images/logo-white.png"
                                         alt="Lynnwood Today">
                                </a>
                                <span class="site-tagline-mobile">Powered by Lynnwood Today</span>

                            </div>

                            <!-- The WordPress Menu goes here -->
                            <div class="collapse navbar-collapse navbar-responsive-collapse pull-left"><ul id="main-menu" class="nav navbar-nav"><li id="menu-item-93278" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93278"><a title="Obituaries" href="https://lynnwoodtoday.com/obituaries/">Obituaries</a></li>
<li id="menu-item-85924" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-85924"><a title="EAT / PLAY / LIVE" href="https://lynnwoodtoday.com/eat-live-play/">EAT / PLAY / LIVE</a></li>
<li id="menu-item-93252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children nav-item menu-item-93252 dropdown"><a title="Events" href="/events/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-93257" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-93257"><a title="Submit Event" href="/events/community/add">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-85188" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-85188"><a title="Health &#038; Fitness" href="https://lynnwoodtoday.com/health-fitness/">Health &#038; Fitness</a></li>
<li id="menu-item-76759" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-76759"><a title="Home &#038; Real Estate" href="https://lynnwoodtoday.com/home-real-estate/">Home &#038; Real Estate</a></li>
<li id="menu-item-93279" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93279"><a title="Sound Silver Living" href="https://lynnwoodtoday.com/sound-silver-living/">Sound Silver Living</a></li>
<li id="menu-item-109731" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-109731"><a title="Weather" href="https://lynnwoodtoday.com/weather/">Weather</a></li>
<li id="menu-item-112331" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-112331"><a title="Restaurants" href="https://restaurants.lynnwoodchamber.org/">Restaurants</a></li>
<li id="menu-item-132506" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-132506"><a title="Election 2022" href="https://lynnwoodtoday.com/category/election-2022/">Election 2022</a></li>
<li id="menu-item-137082" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-137082"><a title="Veterans" href="https://lynnwoodtoday.com/veterans/">Veterans</a></li>
<li class="pc-search-for-mobile"><form method="get" action="https://lynnwoodtoday.com" class="header-search-form" role="search"><input name="s" id="search-input" class="search-field form-control" placeholder="Search" required="" value="" type="search" autofocus><button type="submit"><i class="fa fa-search"></i></button><input type="hidden" name="post_type" value="post"></form></li></ul></div>
                        </div> <!-- .col-md-11 or col-md-12 end -->

                    </div> <!-- .row end -->

                </div> <!-- .container -->

            </div><!-- .navbar -->

        </nav><!-- .site-navigation -->
                    <nav class="trnto-secondary-menu visible-lg-block visible-md-block">
                <div class="container">
                    <div class="row">
                        <div class="col-md-12">
                            <div class="menu-secondary-menu-container"><ul id="secondary-menu" class="nav navbar-nav"><li id="menu-item-93280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children nav-item menu-item-93280 dropdown"><a title="Columns" href="https://lynnwoodtoday.com/category/columns/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Columns <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-95279" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-95279"><a title="Day Trip Discoveries" href="https://lynnwoodtoday.com/category/columns/day-trip-discoveries/">Day Trip Discoveries</a></li>
	<li id="menu-item-95281" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95281"><a title="Fitness Corner" href="https://lynnwoodtoday.com/category/columns/fitness-corner/">Fitness Corner</a></li>
	<li id="menu-item-95282" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95282"><a title="Forward Thinking" href="https://lynnwoodtoday.com/category/columns/forward-thinking/">Forward Thinking</a></li>
	<li id="menu-item-95284" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95284"><a title="Healthy Eating" href="https://lynnwoodtoday.com/category/health-and-fitness/healthy-eating/">Healthy Eating</a></li>
	<li id="menu-item-128788" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-128788"><a title="Home + Work" href="https://lynnwoodtoday.com/category/home-work/">Home + Work</a></li>
	<li id="menu-item-95286" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95286"><a title="Just Around the Corner" href="https://lynnwoodtoday.com/category/just-around-the-corner/">Just Around the Corner</a></li>
	<li id="menu-item-95291" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95291"><a title="Kids are Bookin&#039; It" href="https://lynnwoodtoday.com/category/kids-are-bookin-it/">Kids are Bookin&#8217; It</a></li>
	<li id="menu-item-95292" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95292"><a title="Looking Back" href="https://lynnwoodtoday.com/category/looking-back/">Looking Back</a></li>
	<li id="menu-item-95293" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95293"><a title="Lynnwood Lifestyles" href="https://lynnwoodtoday.com/category/columns/lynnwood-lifestyles/">Lynnwood Lifestyles</a></li>
	<li id="menu-item-95294" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95294"><a title="Playtime" href="https://lynnwoodtoday.com/category/columns/playtime/">Playtime</a></li>
	<li id="menu-item-95295" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95295"><a title="Recommended Reads" href="https://lynnwoodtoday.com/category/columns/recommended-reads/">Recommended Reads</a></li>
	<li id="menu-item-95296" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-95296"><a title="Restaurant News" href="https://lynnwoodtoday.com/category/columns/restaurant-news/">Restaurant News</a></li>
	<li id="menu-item-109167" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-109167"><a title="Under the Weather" href="https://lynnwoodtoday.com/category/under-the-weather/">Under the Weather</a></li>
	<li id="menu-item-113138" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-113138"><a title="The Writer&#039;s Desk" href="https://lynnwoodtoday.com/category/the-writers-desk/">The Writer&#8217;s Desk</a></li>
</ul>
</li>
<li id="menu-item-93194" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93194"><a title="Photos" href="https://lynnwoodtoday.com/category/photos-2/">Photos</a></li>
<li id="menu-item-93196" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93196"><a title="Public Safety" href="https://lynnwoodtoday.com/category/public-safety-2/">Public Safety</a></li>
<li id="menu-item-93281" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93281"><a title="Schools" href="https://lynnwoodtoday.com/category/schools/">Schools</a></li>
<li id="menu-item-93197" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-93197"><a title="Sports" href="https://lynnwoodtoday.com/category/sports-2/">Sports</a></li>
<li id="menu-item-93282" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-93282"><a title="Marketing Services" href="https://lynnwoodtoday.com/business-resources-kaufer-dmc/">Marketing Services</a></li>
</ul></div>                        </div>
                    </div>
                </div>
            </nav>
        
        
    </div><!-- .wrapper-navbar end -->

<div class="wrapper" id="single-wrapper">

    <div id="content" class="container">

        <div class="row">

            <div id="primary"
                 class="col-md-8 content-area">

                <main id="main" class="site-main" role="main">

					
						
<article id="post-137196" class="post-137196 post type-post status-publish format-standard has-post-thumbnail hentry category-education">

	
	<header class="entry-header">
		<h2 class="entry-title">Edmonds School Board hears pleas for improved safety in district&#8217;s schools</h2>
		
		<div class="entry-meta">
			
			<span class="posted-on">Posted: November 10, 2022 </span><span class="post-views"><i class="fa fa-eye"></i> 28 </span>		</div>

	</header><!-- .entry-header -->

	<div class="entry-content">
		<div id="pico"><figure id="attachment_137197" aria-describedby="caption-attachment-137197" style="width: 600px" class="wp-caption alignnone"><img loading="lazy" class="wp-image-137197 size-large" src="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382-600x338.png" alt="" width="600" height="338" srcset="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382-600x338.png 600w, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382-300x169.png 300w, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382-768x432.png 768w, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-382.png 1024w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption id="caption-attachment-137197" class="wp-caption-text">Public commenter Ryan Martin urged the school board to look into other ways to ensure students&#8217; safety in the district.</figcaption></figure>
<p><span style="font-weight: 400;">School safety was the main concern raised by public commenters at the Edmonds School District Board of Directors meeting Tuesday, Nov. 8.</span></p>
<p><span style="font-weight: 400;">Many commenters said their concerns stemmed not only from the </span><a href="https://www.seattletimes.com/seattle-news/law-justice/seattles-ingraham-high-school-shooting-what-we-know/"><span style="font-weight: 400;">Tuesday morning shooting at Seattle’s Ingraham High School</span></a><span style="font-weight: 400;"> that killed one student, but also from a recent incident where </span><a href="https://cleverclassic.com/trending/gyno-horror-stories-relatable-syn/?utm_campaign=Horrible%20Gyno%20Experiences%20FR-CC%20pnp918%20tpd%20VV%3E24%20En%20-%20Unknown%20USA%20FB%20TPD&amp;utm_source=Facebook&amp;utm_medium=Facebook_Desktop_Feed&amp;utm_content=23852411732630541&amp;psl=i_5d3db0&amp;network_code=TPD&amp;ppc=1&amp;fbclid=IwAR1VGVpxfqsi3pTaI6LyjUmYD3v9RJ5VtYUv8-IWAonLca384X9V2wh7ecE"><span style="font-weight: 400;">a gun was found on a student at Edmonds-Woodway High School in September</span></a><span style="font-weight: 400;">.</span></p>
<p><span style="font-weight: 400;">A few commenters asked the board to consider putting police officers back into schools to help kids feel safer.</span></p>
<p><span style="font-weight: 400;">“All of you [board members] don’t have to go to school on a daily basis and worry if you’re going to have someone shoot you,” Deborah Lobe said.</span></p>
<p><span style="font-weight: 400;">Ryan Martin said the district needs to figure out a way to make schools safer, whether by adding a police presence or taking an alternate route.</span></p>
<p><span style="font-weight: 400;">“I’m pleading with you from the bottom of my heart: We need to make our schools safer,” Martin said. “How do we do that? I don’t know. But what we’re doing right now, this ain’t it.”</span></p>
<p><span style="font-weight: 400;">However, Sarah Dilling said police officers in schools do not inherently make them safer, and armed individuals are not going to increase the sense of safety in schools.</span></p>
<p><span style="font-weight: 400;">“Somebody said students learn best when they feel safe,” Dilling said. “Somebody else said kids are so fearful, they need a policeman to make them feel safe, when in fact, the policeman is what makes them not feel safe, for a certain [number] of the kids. Some of the kids don’t feel safe when cops are around. Other kids feel safer. Everyone is different.”</span></p>
<p><span style="font-weight: 400;">Dilling urged the board to look at alternate safety options that do not involve police officers returning to schools.</span></p>
<p><span style="font-weight: 400;">Karen Mosman criticized school staff and questioned why the two students who initially came forward about the gun at Edmonds-Woodway were not taken seriously enough to warrant contacting police.</span></p>
<p><span style="font-weight: 400;">“My question is why did it take three students to report the same incident before action was taken?” she asked.</span></p>
<p><span style="font-weight: 400;">Elizabeth Fleming said one of the students who told staff about the gun was so worried about being targeted for speaking out that they didn’t feel safe going back to class.</span></p>
<p><span style="font-weight: 400;">“These two students that [initially] stepped forward deserve to be honored,” she said.</span></p>
<figure id="attachment_137198" aria-describedby="caption-attachment-137198" style="width: 600px" class="wp-caption alignnone"><img loading="lazy" class="wp-image-137198 size-large" src="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-383-600x338.png" alt="" width="600" height="338" srcset="https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-383-600x338.png 600w, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-383-300x169.png 300w, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-383-768x432.png 768w, https://dpa730eaqha29.cloudfront.net/lynnwoodtoday/wp-content/uploads/2022/11/Screenshot-383.png 1024w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption id="caption-attachment-137198" class="wp-caption-text">Director Gary Noble talked about supporting district students after Tuesday&#8217;s shooting at Seattle&#8217;s Ingraham High School.</figcaption></figure>
<p><span style="font-weight: 400;">Director Keith Smith thanked the community for showing up and voicing their concerns for students in the community.</span></p>
<p><span style="font-weight: 400;">“I’m thankful we have a community out here that is very concerned with our students’ safety,” Smith said. “I respect the fact that maybe not all of us are going to agree on what that looks like, but we should all have a seat at that table to make sure our kids get home safe every day because that’s all we really want.”</span></p>
<p><span style="font-weight: 400;">Director Gary Noble said his heart goes out to all the students and families from Ingraham High School but also voiced his concern to students throughout the region who are now on high alert after the incident.</span></p>
<p><span style="font-weight: 400;">“We will have counselors at all of our high schools tomorrow [Wednesday] but be aware that there’s a lot of angst in our students,” Noble said. “Give them a little extra space and a little extra support if you can.”</span></p>
<p><span style="font-weight: 400;">Director Carin Chase said she hopes the community stands together in the wake of the tragedy.</span></p>
<p><span style="font-weight: 400;">“As we move forward in the [safety] discussion, know that our school board and our community takes this very seriously,” Chase said. “We love our students, we love our community. This is a strong community and I think we can stand together in understanding that a belonging and safe environment for all of our students to learn in is the priority that we can all align upon.”</span></p>
<p><span style="font-weight: 400;">In addition, four public commenters asked the board to delay the planned dual language program implementation at Mountlake Terrace Elementary School. While each commenter said they supported the program, they felt the implementation was too rushed and was setting the program up for failure.</span></p>
<p><span style="font-weight: 400;">“[We] were not given a voice,” teacher Stephanie Schindele said. “We are asking the board … for time. Time for shareholders to have a vote in this important decision. By excluding the people most impacted by this decision, they have been essentially disenfranchised. And as we as a district seek to build equity and inclusion, stifling the voices of these shareholders is unacceptable.”</span></p>
<p><span style="font-weight: 400;">Jennifer Taylor said in a brief discussion between some school staff and the central office staff about the dual language program, the question, “Why not now?” arose.</span></p>
<p><span style="font-weight: 400;">“Why not now?” she asked. “Because central office staff did not survey, meet with nor float this idea with the Mountlake Terrace families, community and family system – meaning all of us together at Mountlake Terrace – before making this decision.”</span></p>
<p><span style="font-weight: 400;">Taylor said community input is the most vital part of ensuring the program’s success, and she doesn’t want to see it be rushed into action and ultimately flop because it was not ready to be implemented.</span></p>
<p><span style="font-weight: 400;">“We are just asking for another year,” teacher Melanie Norris said. “We are on board. [It’s] brilliant. I’m really excited for it. We are behind the program; we are literally just begging for more time. This will serve our community better. This will make our staff feel like a part of the decision and part of how we can make this implementation the best that it can be.”</span></p>
<p><span style="font-weight: 400;">In other business, the board of directors unanimously approved a revised policy for students’ freedom of speech and received a legislative update regarding a board training activity.</span></p>
<p><span style="font-weight: 400;">The approved policy restores the press rights of student journalists, allowing them to tell the stories that matter to their communities without fear of punishment. Exceptions to the district’s new policy include libel, slander, unwarranted invasions of privacy, violation of laws or certain school policies or inciting students to create a clear and present danger of disruption of the orderly operation of the school.</span></p>
<p><em>&#8212; By Lauren Reichenbach</em></p>
</div>	</div><!-- .entry-content -->

	<footer class="entry-footer"></footer><!-- .entry-footer -->

	
</article><!-- #post-## -->


													
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/school-board-hears-pleas-for-improved-safety-in-districts-schools/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://lynnwoodtoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="form-group comment-form-comment">
    <label for="comment">Comment <span class="required">*</span></label>
    <textarea class="form-control" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
    </div><div class="form-group comment-form-author"><label for="author">Name <span class="required">* (First and last required)</span></label> <input class="form-control" id="author" name="author" type="text" value="" size="30" aria-required='true' required /></div>
<div class="form-group comment-form-email"><label for="email">Email <span class="required">*</span></label> <input class="form-control" id="email" name="email" type="email" value="" size="30" aria-required='true' required /></div>
<div class="form-group comment-form-address"><label for="address">City/State of Residence <span class="required">*</span></label> <input class="form-control" id="address" name="address" type="text" value="" size="30" aria-required='true' required /></div>
<div class="form-group comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30" /></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='137196' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="77d9ff5775" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="191"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	        <p style="color: green; font-weight: bold;">
            Real first and last names — as well as city of residence — are required for all commenters.
            <br/> This is so we can verify your identity before approving your comment.
        </p>
	
</div><!-- #comments -->
						                        <!-- add subscribe from -->
						<div class="subscribe-panel">

	<h3 class="subscribe-heading">Lynnwood Today</h3>
	<p><strong>Sign Up for Our Daily Lynnwood Newsletter</strong></p>

	<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.8.10 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-71903 mc4wp-form-theme mc4wp-form-theme-red" method="post" data-id="71903" data-name="Newsletter" ><div class="mc4wp-form-fields"><div class="subscribe-form torontopro-mailchimp-form">
    <input type="email" name="EMAIL" placeholder="Enter your email address" style="width:60% !important;margin-bottom:10px !important" required />
    <script src="https://www.google.com/recaptcha/api.js" async defer></script>
	<div class="g-recaptcha" data-sitekey="6LeL930UAAAAADYqKapnDDA3PYjy1BfUlNbH13Nw"></div>
  	<input type="submit" value="Sign Up" style="width:60%;margin-top:10px" />
</div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1668143950" /><input type="hidden" name="_mc4wp_form_id" value="71903" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin -->
</div>

<!--                        <section class="related-posts-area">-->
                            <!-- <h4 class="related-posts-area-heading">-->
							<!--</h4>-->

							
<!--                            <div class="trnto-next-post-nav" data-id="--><!--"></div>-->

<!--                        </section>-->

					
                    <div class="back-to-home text-center">
                        <a href="https://lynnwoodtoday.com">BACK TO HOME</a>
                    </div>

                </main><!-- #main -->

            </div><!-- #primary -->

            <div id="secondary" class="col-md-4 widget-area hidden-xs hidden-sm single-post-sidebar"
                 role="complementary">

				<aside id="bs_zones-44" class="widget bs_zones"><div><broadstreet-zone zone-id="83032" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-22" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="32659" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-59" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="99160" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-21" class="widget bs_zones"><div><broadstreet-zone zone-id="48295" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="decent_comments_widget-3" class="widget widget_decent_comments_widget"><h3 class="widget-title">Recent Comments</h3><div class="decent-comments"><ul><li><div class="comment"><span class="comment-author">Lynda Doctorello</span><span class="comment-date"> Nov 8, 2022 at 1:23 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/restaurant-news-broadway-pea-salad-similar-to-that-served-at-scotts/#comment-36601">Restaurant News: Broadway Pea Salad similar to that served at Scott&#8217;s</a></span><span class="comment-excerpt">Scott's bar and grill was Clinker daggers before it was Scott's. We use to meet there after work years ago.</span></div></li><li><div class="comment"><span class="comment-author">Administrator</span><span class="comment-date"> Nov 7, 2022 at 1:16 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/pud-still-working-to-repair-windstorm-damage-power-remains-out-for-thousands-locally/#comment-36599">PUD still working to repair windstorm damage; power remains out for thousands locally</a></span><span class="comment-excerpt">Comcast replies that its Internet, TV and telephone services for homes and businesses require commercial power to operate. During a</span></div></li><li><div class="comment"><span class="comment-author">Charley Delaney</span><span class="comment-date"> Nov 7, 2022 at 12:11 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/pud-still-working-to-repair-windstorm-damage-power-remains-out-for-thousands-locally/#comment-36598">PUD still working to repair windstorm damage; power remains out for thousands locally</a></span><span class="comment-excerpt">Apparently several thousand Comcast Xfinity customers in the Martha Lake area are without service since Friday night, but the company</span></div></li><li><div class="comment"><span class="comment-author">Administrator</span><span class="comment-date"> Nov 5, 2022 at 8:45 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/artists-sought-for-large-scale-work-near-mlt-light-rail-station/#comment-36593">Artists sought for large-scale work near MLT light rail station</a></span><span class="comment-excerpt">Hi Barbara --I suggest you click on the link for more details. </span></div></li><li><div class="comment"><span class="comment-author">Barbara Ersfeld</span><span class="comment-date"> Nov 5, 2022 at 6:42 pm</span><span class="comment-link"> on <a href="https://lynnwoodtoday.com/artists-sought-for-large-scale-work-near-mlt-light-rail-station/#comment-36592">Artists sought for large-scale work near MLT light rail station</a></span><span class="comment-excerpt">I’d like more info on what sort of art work is expected. </span></div></li></ul></div></aside><aside id="text-31" class="widget widget_text">			<div class="textwidget"><p><a href="https://lynnwoodtoday.com/comments/">More recent comments</a></p>
</div>
		</aside><aside id="bs_zones-24" class="widget bs_zones"><div><broadstreet-zone zone-id="1489" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_multiple_zones-4" class="widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script><script type="text/javascript">broadstreet.zone(1490);</script></aside><aside id="bs_multiple_zones-5" class="widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script><script type="text/javascript">broadstreet.zone(1488);</script></aside><aside id="bs_zones-25" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="56629" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-26" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="65027" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-27" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="66393" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-38" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="80691" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-39" class="widget bs_zones"><div><broadstreet-zone zone-id="80692" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-29" class="widget bs_zones"><div><broadstreet-zone zone-id="72356" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-33" class="widget bs_zones"><div><broadstreet-zone zone-id="72356" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-30" class="widget bs_zones"><div><broadstreet-zone zone-id="72251" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-31" class="widget bs_zones"><div><broadstreet-zone zone-id="68224" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside><aside id="bs_zones-57" class="widget bs_zones"><div><broadstreet-zone place="" zone-id="68223" keywords="not_home_page,not_landing_page,is_article_page,education,school-board-hears-pleas-for-improved-safety-in-districts-schools,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></aside>
            </div>

        </div><!-- .row -->

    </div><!-- Container end -->

</div><!-- Wrapper end -->


<div class="wrapper footer-area" id="wrapper-footer">

	<div class="footer-top-area">

		<div class="container">
			<div class="row">

				<div class="col-md-8 col-xs-12">
					<div class="footer-menu-area">
						<div class="menu-footer-menu-container"><ul id="footer-menu" class="menu"><li id="menu-item-93201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93201"><a href="https://lynnwoodtoday.com/commenting-policy/">Commenting Policy</a></li>
<li id="menu-item-93200" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93200"><a href="https://lynnwoodtoday.com/our-policy-on-reproducing-content/">Our Policy on Reproducing Content</a></li>
<li id="menu-item-93202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93202"><a href="mailto:teresa@myedmondsnews.com">Submit News</a></li>
</ul></div>					</div>
				</div>

				<div class="col-md-4 col-xs-12">
					<div class="footer-social-icons">
						<a href="https://www.facebook.com/LynnwoodToday/" target="_blank"><i class="fa fa-facebook"></i></a>
						<a href="https://twitter.com/lynnwoodtoday" target="_blank"><i class="fa fa-twitter"></i></a>
						<a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
					</div>
				</div>

			</div>
		</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">

		<div class="container">
			<div class="row">

				<div class="col-md-6 col-xs-12">
					<div class="site-dev-info">
						<p>Website by <a href="https://webpublisherpro.com" target="_new">Web Publisher PRO</a></p>
					</div>
				</div>

				<div class="col-md-6 col-xs-12">
					<div class="site-info text-right">
						<p>&copy; Copyright 2022 | All rights reserved by <a class="site-name" href="https://lynnwoodtoday.com/" rel="home">Lynnwood Today</a></p>
					</div><!-- .site-info -->
				</div>

			</div>
		</div>

	</footer>

	<div class="scroll-up" style="display: block;">
        <i class="fa fa-angle-up"></i>
    </div>

</div><!-- wrapper end -->

</div><!-- #page -->

		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>        <script>
            var wordLimit = Number('300');
            jQuery(window).load(function () {
                jQuery('.form-group.comment-form-comment').append('<p class="comment_limit">' +
                    'Total: <span id="display_count">0</span> words. Words left: <span id="word_left">' + wordLimit + '</span></p>');
                jQuery('#subscribe-reloaded').attr('checked', 'checked');
                jQuery("#commentform").removeAttr("novalidate");
            });
            jQuery(document).ready(function () {
                jQuery("#comment").on('keyup', function () {
                    var words = this.value.match(/\S+/g).length;
                    if (words > wordLimit) {
                        var trimmed = jQuery(this).val().split(/\s+/, wordLimit).join(" ");
                        jQuery(this).val(trimmed + " ");
                    }
                    else {
                        jQuery('#display_count').text(words);
                        jQuery('#word_left').text(wordLimit - words);
                    }
                });
            });
        </script>
	<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><div id='pico-widget-container'></div><script src='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script src='https://lynnwoodtoday.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/wp-util.min.js' id='wp-util-js'></script>
<script type='text/javascript' id='themeplate-scripts-js-before'>
var trntoAjaxUrl='https://lynnwoodtoday.com/wp-admin/admin-ajax.php';
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/themes/toronto-pro/assets/js/theme.min.js' id='themeplate-scripts-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='//checkout.stripe.com/v2/checkout.js' id='stripe-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/sumo/sumoselect.js' id='wdp-sumoselect-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/maplace/maplace.js' id='maplace-js'></script>
<script type='text/javascript' id='wdp-frontend-script-js-extra'>
/* <![CDATA[ */
var wdp_checkout_params = {"key":"","label":"Pay For Claiming","amount":"20000","currency":"usd","name":"Lynnwood Today"};
/* ]]> */
</script>
<script type='text/javascript' id='wdp-frontend-script-js-before'>
var hideOnMobile = true;
</script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/web-directory-pro-v2/assets/js/frontend.js' id='wdp-frontend-script-js'></script>
<script type='text/javascript' src='https://lynnwoodtoday.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script defer type='text/javascript' src='https://lynnwoodtoday.com/wp-content/plugins/akismet/_inc/akismet-frontend.js' id='akismet-frontend-js'></script>
<script type='text/javascript' defer src='https://lynnwoodtoday.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js' id='mc4wp-forms-api-js'></script>

</body>

</html>
